K0s latest release is killing my rpi4b CPUs :(

i’m having a hard time making k0s working smoothly on my raspberry pi 4B 8go cluster.
I have several nodes composing the cluster and for a weird reason, the control plane is CPU killing.

tried the same installation on a Rock64 cluster which works perfectly.

Raspberry pi 4 cluster description:

  • OS: ubuntu 22.04 LTS 64bits
  • k0s version: v1.26.2+k0s.1
  • CNI : calico
  • kubeproxy: enabled

screenshot from the rpi4 cluster below:

Rock64 cluster description:

  • OS: Armbian Jammy 64bits
  • k0s version: v1.26.2+k0s.1
  • CNI : calico
  • kubeproxy: enabled

what’s going on ?
any hints ?

Hi @xinity,
do you see any problems in the logs?

Hey there,

Here’s an example of what the logs are saying: k0s-error-logs-rpi4 · GitHub

Hoping it will help ,

Let me know :slight_smile:


@jhennig I’ve worked on narrowing down the culprit

The issue is 100% related to the konnectivity agents and server.

I just don’t know why!

Any hints would be highly appreciated :pray:

Update @jhennig , this occurs once i deploy the cluster with 2 contrôle plane nodes.

@xinity Maybe it’s a similar problem as described in k0sproject/k0s#2888? Please have a look at the comment from @juanluisvaladas. Hope that helps.

I’ve filed k0sproject/k0sctl#475, so that k0sctl might give a hint about known-bad configurations.

1 Like

hello @twieczorek i felt into the “no LB case” as i was desperately trying to make kube-vip working INCLUSTER at boot time with no luck :frowning:

I’ve switched back into specializing two of my nodes for the haproxy/keepalived and it seems to be working.

I know have a weird situation where the cilium deployment is deleted by the cluster after a certain period of time and i don’t know why :frowning:
I’ll open another thread for that