Upgrade met with Uncaught Exception

Uncaught Exception:
Error: dlopen(/Applications/Lens.app/Contents/Resources/app.asar.unpacked/node_modules/node-pty/build/Release/pty.node, 0x0001): tried: '/Applications/Lens.app/Contents/Resources/app.asar.unpacked/node_modules/node-pty/build/Release/pty.node' (mach-o file, but is an incompatible architecture (have 'arm64', need 'x86_64h' or 'x86_64')), '/System/Volumes/Preboot/Cryptexes/OS/Applications/Lens.app/Contents/Resources/app.asar.unpacked/node_modules/node-pty/build/Release/pty.node' (no such file), '/Applications/Lens.app/Contents/Resources/app.asar.unpacked/node_modules/node-pty/build/Release/pty.node' (mach-o file, but is an incompatible architecture (have 'arm64', need 'x86_64h' or 'x86_64'))
at process.func [as dlopen] (node:electron/js2c/node_init:2:2107)
at Object.<anonymous> (node:internal/modules/cjs/loader:1356:18)
at Object.func [as .node] (node:electron/js2c/node_init:2:2334)
at Module.load (node:internal/modules/cjs/loader:1126:32)
at node:internal/modules/cjs/loader:967:12
at Function._load (node:electron/js2c/node_init:2:13357)
at Module.require (node:internal/modules/cjs/loader:1150:19)
at require (node:internal/modules/cjs/helpers:121:18)
at Object.<anonymous> (/Applications/Lens.app/Contents/Resources/app.asar/node_modules/node-pty/lib/unixTerminal.js:29:11)
at Module._compile (node:internal/modules/cjs/loader:1271:14)

I’ve redownloaded the official version of Lens and reinstalled it, followed by updating from the Beta Channel (multiple times) and I’m met with the same error.

Specs & Operating System
2019 MacBook Pro (Intel based)
MacOs Sonoma 14.3.1

Hi @kyle-arnone ,

Thanks for your feedback, I’m passing it along to the dev team. :slight_smile:

1 Like

@kyle-arnone Did you download the Apple silicon version of Lens?

If yes, could you please try downloading the other one and tell me if it works?

I’m getting the same. Have re-downloaded the Intel version (I have an intel mac) and after updating to the Beta channel, it throws this exception.

Thanks, the Mac Intel build is broken in the latest update, we’re working on fixing it asap.


Can you try updating again? It should be fixed now.

@emeste Definitely the Intel version
@phorsmalahti Looks like the latest update addresses that problem. Thank you!

Thanks for your help! :slight_smile:

I’m happy it’s working now!

Working for me now, thank you!

1 Like

Thanks for confirming! :slight_smile: