Lens 2023.12.281947-latest - Release

We are happy to announce a patch release for Lens Desktop. This update includes the bug fix below.

To ensure a smooth transition and minimize disruption we’ll start by rolling out the update to a small portion of our users, then incrementally increasing this number until all users have access to the update. If you have not received the update and wish to you can download this release manually at our website .


  • The table search has been replaced by a search bar that can be pinned so it stays open.
  • Metrics 2.0. The events are displayed in the Metrics chart. Prometheus is updated in Lens Metrics. Users can now zoom with your mouse and see a custom selected time range option.
  • Fixed downloading kubectl versions on demand.
  • Shareable links. Users can link to clusters or specific sections inside the cluster.

Bug fixes

  • Fixed Prometheus path parsing.
  • Fixed increase terminal timeout.
  • Added share pod link.
  • Disabled name column dragging.
  • Fixed Validate weblinks with a redirect as valid.
  • Fixed remove catalog drawer menu border.
  • Fixed don’t show share URL for weblinks.
  • Fixed extension install hang.
  • Fixed display share menu only on mac.
  • Fixed Show latest value for HelmReleases when the release secrets update.
  • Fixed Metrics for pods with multiple containers.

Does your team plan to fix the shell-related issue I reported 4 months ago Can not exec to pod when update 2023.9.290703 on MacOS

After this update, I cannot use terminal, its stuck on Connecting …

Cannot use terminal after last update 2023.12.281947-latest

1 Like

Hi @peanutnbt and @akkadej

Thanks for your messages!
I forwarded them to the dev team.

We’ll let you know when we get an answer. :slight_smile:

MacOS 14.2.1
i update the 281947 i cant open lens

Had the same experience…tried it again on the same pod and it worked. Tried a few more and was able to shell into the rest. Seems to have only happened on the first try.

1 Like

Search button on top right, while searchbar on bottom is pita on a large monitor. Would be nice if it is possible to be able to move the searchbar at the top (e.g. at least with a settings option)

1 Like

@ivonkrastev thanks for your feedback, we are looking into this!

@wojtek @macoplus and @akkadej: Would you please be so kind and test if your issues are solved with the latest release? Thanks for reporting this!

1 Like